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Introduction 
This tutorial will introduce and familiarize you with the basic functions and features of 
STK/Scheduler; you will start the STK/Scheduler module, specify a planning period, define 
various tasks and the resources that they require, import access data and event reports from 
STK to help define task scheduling opportunities, and solve the scheduling problem using 
two of the available deconfliction and optimization algorithms.  In addition, you will exercise 
the various controls for on-screen schedule viewing and generate task and resource-based 
ASCII reports.  This tutorial generally takes a little more than one hour to complete. 

 
 

Licenses Needed 
This tutorial requires that you have STK/Scheduler installed and licensed (version 

3.2 or higher).  STK version 6.0 or higher and STK/Connect are also required. 
 

 

If you would like additional information about any of the options and fields on any 
STK/Scheduler form as you go through this exercise, please use the form-specific 
STK/Scheduler HTML Help available by clicking on the “?” button on any form. 
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Setup 

Start the STK/Scheduler module by double-clicking on the STK/Scheduler icon on the 
desktop.  The following STK/Scheduler blank main Gantt view window will appear.  Resize 
the window to make it larger, if desired: 

 

STK/Scheduler works with schedule files, similar to the way Microsoft Word works with 
document files: Everything about a scheduling problem (including its solution) is saved in a 
schedule file.  Give the current blank file a name so that you can save your work and come 
back to it later; select File > Save As. . . .  Enter the filename “STKscheduler Tutorial” and 
browse for the directory where you want to save it, then click Save: 
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In order for STK objects and related access data and event reports to be applied to the 
scheduling problem definition (and solution), you need to associate your STK/Scheduler 
planning file with a specific STK scenario file.  Select Schedule > STK > Load STK 
Scenario. . . , click Change Scenario, and select the Tutorial.sc scenario file from the:  

[Installation Drive]:\Program Files\AGI\STK 6.0\ Help\Scheduler\Scenarios\Tutorial 
directory: 

 

Click OK; STK/Scheduler will start STK and load the selected scenario.  After the scenario 
loads, go ahead and minimize the STK forms or bring the STK/Scheduler form to the front. 

Next, set the schedule period start and stop times.  Select Schedule > Define Start/Stop. . . 
and the following form will appear: 
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Set the Start Time to 2003/1/03 00:00:00 and the Stop Time to 2003/1/05 00:00:00 and click 
OK.  This sets a two-day period for scheduling for this planning file.  All recurring tasks, 
access calculations and other time-related information will be bounded by the start and stop 
times defined for the schedule file.  The schedule file schedule time period is shown in the 
lower left corner of the main STK/Scheduler form at all times. 

Verify that the STK/Scheduler software has updated the STK scenario times to match the 
schedule start/stop times by right-clicking on the Tutorial scenario object in the STK Object 
Browser, and selecting Properties Browser: (verify start and stop times): 

 

Close the Basic Properties window and minimize the STK window. 
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Defining Resources 
STK/Scheduler solves task scheduling problems related to limited resources.  Before tasks 
can be defined the resources that they require must be defined.  This portion of the exercise 
defines seven resources that will be used as resource options to support the tasks defined in 
the next section of the exercise.  Expect this section of the tutorial to take about 20 minutes to 
complete. 

To define a new resource select Resource > New/Insert.  This will bring up the Resource 
Definition form, General tab: 

 

Type FUSE in the Resource Name field and click on Browse STK Objects to select the 
FUSE satellite object from the available STK scenario objects.  This will associate the FUSE 
resource in the STK/Scheduler schedule file with the FUSE satellite object in the associated 
STK scenario for the purposes of access calculations and event reports. 

Don’t worry about the other resource definition tabs for now.  Default values will be assigned 
for Availability (always available), Accommodation (support maximum of 1 task at a time), 
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Capacity (n/a), Notes (none), and Status (blank until scheduling is performed).  You will use 
these tabs for other resource definitions in this section. 

Click OK to apply the new resource to the schedule file.  You will see the resource listed in 
the resource availability section at the bottom of the Gantt view window: 

 

The aqua-colored bar to the right of the resource name shows the resource availability against 
the schedule timeline.  The line is solid since we did not change the “always available” 
default definition for resource availability.  Note that this availability is for the resource in 
general and does not intend to represent STK accesses that will be applied on a task-specific 
basis later in this exercise. 
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A quicker way to define resources that are associated with STK objects is to use the STK 
ingest tool.  Select Resource > Ingest from STK and select All: 

 

Select the following STK scenario objects from the list for ingest as planning file resources 
and then click OK button after all are highlighted (depress the keyboard CTRL key while 
clicking on each item with the mouse): 

• /Scenario/Tutorial/Facility/Goldstone26 

• . . . /Facility/Guam46 

• . . . /Facility/Madrid26 

• . . . /Star/CassiopeiaStar_HR-21 

• . . . /Target/AmazonTarget 

Note that each of the new resources has been added to the FUSE resource at the bottom of the 
STK/Scheduler Gantt view.  All of these new resources have default attribute values and are 
associated with their applicable STK scenario object. 

Next, we are going to edit some of the attributes of some of these new resources.  Start by 
right-clicking on the Madrid26 resource and select Edit from the resource popup menu.   

On the General tab define the Default Setup Time for the Madrid ground station to be 10 
minutes: 
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Setup time uses resource accommodation prior to a task’s assigned time in the schedule.  
Note that full task timeslot availability is not required in order for a resource to be available 
for setup operations. 

Next select the Availability tab: 

 

Note that the Define Blackout Times – Default Available option is selected.   

Define a single blackout period for this resource by selecting the Discrete Windows tab and 
clicking on Add: 
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Define the Window Start time to be 2003/01/04 06:00:00 and the Window Stop time to be 
2003/01/04 12:00:00.  Specify in the Comments field Antenna Maintenance and click OK.  
The blackout period is now listed in the Availability windows list for this resource: 
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Click OK from this form to apply the change to the resource.  Back on the STK/Scheduler 
main form select View > Timescale View Properties: 

 

Select Hours for the Scale and select Minimize Zoom checkbox in the Zoom frame and click 
OK.  The white area in the Madrid row indicates that the resource is not available for use 
during that time period which you just defined: 
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Now we will change the priority of one of the resources.  Right-click on the Guam46 
resource and select Edit from the resource pop-up menu.   

 

On the General tab change the Priority to 8 and click OK.  This will make the Guam ground 
station a lower priority than Goldstone or Madrid (both still set at the default priority value of 
5 (middle of 1-10 default range)).  The deconfliction algorithms take resource priority into 
account when multiple resource options are available for a task.  Changing Guam to a priority 
of 8 essentially makes Guam a backup to Goldstone and Madrid (it is a less desirable 
assignment).  Global resource priorities can be overridden on a task-by-task basis. 

 

 
Note 

The range and convention for task and resource priority schemes within 
STK/Scheduler are configurable by the user under the Schedule > Properties 

menu, Task Priority and Resource Priority tabs. 
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Next we will apply an STK report to help specify the general availability of the Amazon 
resource.  Right-click on the AmazonTarget resource at the bottom of the STK/Scheduler 
main Gantt form view and select Edit.  Go to the Availability tab: 

 

Select the Define Availability Times – Default Unavailable option.  Select the Discrete 
Windows tab and click on STK Import.  The STK Report Definitions form will appear (and 
will be blank because you have not defined any reports yet).  Click Add to bring up the 
Define STK Time Report form: 
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Select the Sun Report Type and AmazonTarget for STK Object 1.  Click OK to accept the 
report definition and OK again to confirm that this is the only report to apply, and then 
confirm that the target sunlight windows for the defined two-day period are returned in the 
Availability windows area: 

 

These sunlight windows were retrieved from the STK software.  Click OK again and note 
that the Amazon resource now has two defined availability periods (colored aqua bars) 
corresponding to the times when it is in the sun. 
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Another we are going to define is a mission operations team and is not associated with an 
STK object.  STK/Scheduler is not limited to STK resources; any kind of resource can be 
defined and used as a task requirement. 

Select Resource > New/Insert.  Under the General tab define the Resource Name as 
OpsTeam.  Select the Availability tab and choose Define Availability Times – Default 
Unavailable.  Select the Periodic Windows tab and click on Add to bring up the Periodic 
Definition window and define the periodic times during which the OpsTeam will be available 
(when the controllers are in the control center): 

 

For Frequency select Daily, then click Add to specify specific times during the day when the 
OpsTeam resource is available: 

 

Define the window with start time to be 08:00:00 and the duration to be 4 hours.  Click OK 
to apply the window.  Then click Add again to define another window.  Specify the start time 
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of the window to be 13:00:00 with a duration of 4 hours, and click OK to apply this second 
window.  Two windows are now defined in the Periodic definition for the OpsTeam.   

 

These morning and afternoon shifts will be applied each day of the planning file period. 

Click OK for the Periodic Definition tab, select the Accommodation tab and note that the 
default accommodation is 1 (number of simultaneous tasks that can be supported by the 
resource).   

 

Change the Maximum Accommodation to 2 for the OpsTeam.  This indicates that the 
OpsTeam resource can support up to 2 tasks simultaneously: They can do two things at once.  
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This will allow the OpsTeam to write a report and support a satellite contact at the same time, 
for instance. 

Click OK again and confirm the OpsTeam resource on the main Gantt form and the expected 
shift times shown as aqua-colored bars (2 pairs of 4-hour periods, 1 pair for each day). 

 

The last resource we will define is an onboard solid-state-recorder (SSR).  This resource will help 
demonstrate the use of the resource capacity attribute in task scheduling.  Again select Resource > 
New/Insert, will bring up the Resource Definition form, General tab.  Name the resource 
“SSR”, and then click on the Capacity tab (we are going to leave all other attributes in their 
default state). 

Select the Is Applicable checkbox at the top of the tab.  Capacity is not applicable to all 
resources, just those that have capacity that can be depleted or replenished (like a recorder).  
Define “Mbytes” in the Unit Definition field.  This will help the user employ consistent units 
when defining tasks that use this resource capacity.  Under Type Definition select 
Consumable.  This means that resource capacity is permanently depleted (or replenished) by 
a task.  The alternative, Resilient, means that resource capacity is depleted/replenished only 
for the duration of the task.  Specify Min Capacity as 0, and Max Capacity and Init Capacity 
as 100.  Lastly, select Soft Maximum Limit for resource Max Capacity . . . this will allow 
for partial replenish activities even when the resource capacity is not fully depleted.  Refer to 
the window snapshot on the next page to confirm your SSR capacity definitions.  Now click 
OK to complete your SSR resource definition.   
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Some resources, especially passive resources like targets, are often best defined as having Unlimited 
Accommodation (they never get “used up”).  Edit the AmazonTarget and CassiopeiaStar_HR21 
resources and note that their Accomodation is already set to Unlimited Accommodation 
(checkbox on Resource Accomodation tab).  As a default, resource Accomodation for Stars, 
Planets, Point Targets, and Area Targets ingested from STK (using the Resource > Ingest 
from STK function or via the API) is set to Unlimited.  For all other STK object types and for 
all resource definition through the GUI (Resource > New) regardless of STK object type, 
default accomodation is 1. 

You have now defined eight resources for use in this planning file:  3 ground facilities 
(Madrid, Goldstone, and Guam), 1 satellite (FUSE), an ops team (OpsTeam), a ground target 
(AmazonTarget), a star (CassiopeiaStar_HR-21), and an onboard recorder.  Madrid, the ops 
team, and the ground target have limitations on their availability specified. 

Now is a good time to take a break and stretch your legs.  Select File > Save to save your 
work if you have not done so already.  After your break, continue on with the Defining Tasks 
section to define and deconflict tasks that use the resources you have defined here. 
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Defining Tasks 
In this section you will define 5 separate tasks with differing constraints and resource 
requirements including: 1) a recurring satellite to ground station communications task, 2) a 
daily management report task that requires no STK resources, accesses, or reports, 3) a single 
instance task to take a picture of a ground target with a satellite while the target is in sunlight, 
4) a single instance task to make an observation of a star with a satellite during satellite 
umbra, and 5) a satellite attitude calibration task that occurs once an orbit within 30 minutes 
of the ascending node crossing.  Expect this section to take about 30 minutes to complete. 

FUSEcomm Task 

Select Task > New/Insert. . . to define a new task, and the Task Definition form (General tab) 
will be displayed: 

 

Enter FUSEcomm in the Task Name field.  For this task on the General tab keep the default 
values; leave the Priority at the default of 5 (middle of range), keep the Scheduling 
Preference as No Preference, and do not specify any Group memberships. 
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Select the Scheduling tab and choose Recurring Task, then choose Time for Scheduling 
Windows Defined by (as opposed to windows defined by Resource Availability which would 
be used for a task that occurs every time a satellite sees a ground station, for instance).  You 
will see a pair of tabs at the bottom of the window that allows the user to define the time-
based recurring nature of the task: 

 

Select the Periodic Windows tab and click Add to define the periodic windows during which 
you would like this task to be scheduled: 

 

 
V3.0.0 May, 2004 



20 STK/Scheduler Tutorial 

Select a Frequency of Daily and specify Repeats per Period as 3.  Leave the periodic start 
and stop times as the default (planning period start and stop).  This specifies that the task 
should be scheduled 3 times a day for the duration of the planning period.  Additional 
restrictive scheduling windows could be specified using the window definitions option at the 
bottom of this tab, but leave this undefined for now; we’ll the let the deconfliction engine do 
the hard work for us later.  Click OK for the Scheduling window definition. 

 

 
Note 

Several periodic definitions could be specified for a single recurring task, and 
the user could also specify discrete windows during which the task should 
also be attempted.  The software will attempt to schedule an instance of the 

task during each and every window defined by the user the specified number 
of times (which can vary for each window defined). 
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Now that the windows during which the FUSEcomm task should be scheduled are defined, 
select the Duration tab to specify the duration of each instance of the task itself: 

 

Select Maximize Duration – no handovers and specify a Minimum Duration of 0 days, 
00:08:00 (8 minutes) at the bottom of the tab.  Leave the maximum duration as the default 
value of Unlimited.  This will maximize the duration of the task assignment within the 
window of a single resource set (no handovers to another ground station). 

Select the Resources tab to define the resource requirements and options for the task: 
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All of the resources defined in this planning file are listed under the Defined Resources list on 
the left.  Resources associated with an STK object have their STK object symbol next to them 
(satellite, facility, target, star, etc.).  To define the logical resource requirements formula for 
the FUSEcomm task: 

• Double-click on the FUSE resource in the Defined Resources listing 
• Click on the AND button 
• Double-click on the OpsTeam resource 
• Click on the AND button 
• Double-click on the SSR resource 
• Click on the AND button 
• Click on the ( ) button (parenthesis) 
• Double-click on Goldstone26 resource 
• Click on the OR button 
• Double-click on the Madrid26 resource 
• Click on the OR button 
• Double-click on the Guam46 resource 

The Resource Constraints formula defines the resource requirements and options with a 
logical AND/OR statement.  The FUSEcomm formula specifies that the task always requires 
the FUSE and OpsTeam and SSR resources, plus any one of three ground station resources 
(Guam, Madrid, or Goldstone). 

 
Note 

Any level of parenthesis nesting is allowed, and there is no limit on the 
length of the formula. 

 

Click Create Possibilities and the software will determine all of the individual resource string 
options (Possibilities) that could be used to accomplish the task and will apply appropriate 
STK access constraints (since the checkbox is selected).  Select the Timeslot Definitions tab 
to view information about each resource possibility string: 
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Note the three Resource Possibilities for the FUSEcomm task based on the defined Resource 
Constraints formula from the previous tab.  The Possibility Priority values are calculated 
based on the priority of each resource in the individual Possibility string.  To manually edit 
the task-specific Priority of a Possibility, highlight the FUSE, OpsTeam, SSR, Madrid26 
possibility option and click Edit Priority: 

 

Enter a value of 9 and click OK.  Note the change in Priority value for the FUSE, OpsTeam, 
SSR, Madrid26 possibility. 

 
 

Note 
Note that the range and convention for Possibility priority is the same as that 

for Resource priority. 

 

As a default, constrained accesses will be required between any STK object-related resources 
in each resource possibility string.  Access calculations are requested from STK and applied 
by the STK/Scheduler software during the Create Possibilities step. 
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Note 

Accesses between ground objects in the same possibility string are not 
applied.  Individual accesses may be deleted from the automatically 

generated list by clicking on the STK Import button. 

 

To view the affects of resource availability constraints vs. access opportunities and how they 
combine to define the final “timeslots” (scheduling opportunities) for the task, click on the 
Reports radio-button at the bottom of the form (shows STK accesses for the highlighted 
possibility string).  Click on another possibility string to see the STK accesses related to this 
option.  Other STK reports (and/or external time files) may be applied by the operator as 
required.  Only when all reports (and file times) are satisfied (report overlaps) will report 
windows be created for the possibility. 

Click on the Resource Availability radio-button to display the times during which all 
resources in the highlighted possibility string are available at the same time.  Click on each of 
the possibility options and note that the one containing Madrid is missing one of the resource 
availability windows (because the Madrid facility has a blackout period defined that covers 
the entire morning shift of the OpsTeam on day two of the schedule): 

 

The Click on the All Timeslots radio-button option to see when the resource availability and 
accesses overlap (these are the final timeslot options).  Select each possibility option in turn 
to see the final timeslots for each. 

 
STK/Scheduler v8.0 August, 2006 



STK/Scheduler Tutorial 25 

Next, click on the Timeslots Per Task radio-button option at the top of the tab to see a listing 
of each final task timeslot regardless of the resources involved (resources supporting each 
timeslot are listed in the table): 

 

Adjust the column widths or scroll to the right so that the timeslot Desirability column is 
visible.  Timeslot Desirability is a measure of the desirability of a specific timeslot vs. other 
timeslots for that task, and is taken into account by the deconfliction algorithms when scoring 
different schedule solution options against each other.  The Desirability of a specific timeslot 
is calculated based on the related Possibility priority and the Scheduling Preference for the 
task (see the Task Definition window General tab), and is scaled from 0 to 100, with 100 
being the highest preference. 

Calculated timeslot desirability scores can be manually adjusted by the user.  Highlight a 
specific timeslot row in the Timeslot Definitions window at the bottom of the page and click 
Edit to bring up the Timeslot editing window: 
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Change the Desirability value to 50 and click OK.  Note the updated timeslot desirability 
value in the timeslots window.  This change makes this particular timeslot option less 
desirable than the others. 

Select the Resource Usage tab and confirm the Define Per Task radio-button option: 

 

Specify a Setup time of 5 minutes for each of the ground station resources (Guam, Goldstone, 
and Madrid) by clicking on each resource in turn to highlight it, clicking Edit, and filling in 5 
minutes (0 days, 00:05:00) under Setup Time at the bottom of the form: 
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Click OK each time to return to the Resource Usage tab.  For Madrid, this task-specific 
resource setup time will override the default Madrid setup time defined in its resource 
definition (but only for this task). 

Next, select the SSR resource, click Edit, and specify that the FUSEcomm task Replenishes 
the SSR resource at a Rate of 0.1 Mbytes per second and click OK.  Refer to the window 
snapshot below to confirm the settings. 
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Click OK to apply the task definition.  Six tasks (plus a recurring task Parent definition) will 
be added to the STK/Scheduler main window Gantt view. 

 
Note 

FUSEcomm is attempted 3 times a day for a 2-day scheduling period, so the 
software treats it as 6 separate tasks 

 
 

De-select View > Show Task Parent Definitions to hide the Parent task definition. 
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The timeslots for each task are shown in the Gantt schedule area in the associated task row.  
Note that no scheduling has been done yet.  The displayed windows are simply the times 
when the task could be accomplished based on resource availability, scheduling window 
times, and STK accesses (if applicable). 

Place the mouse cursor/pointer over one of the timeslot windows in the Gantt view and a 
popup form will appear that specifies the resources supporting that timeslot and the start time, 
stop time, duration, and resources associated with the selected timeslot. 

Management Report Task 

Select Task > New/Insert.  On the General tab of the Task Definition form specify the Task 
Name as Management Report.  Leave all else on the General tab as default values. 

Select the Scheduling tab and select the Recurring Task radio-button option and Time as the 
recurring basis.  Select the Periodic tab and click Add.  Select a Frequency of Daily and click 
OK (leave Repeats per Period in its default value of 1). 

Select the Duration tab and select the Fixed duration option.  Specify the duration as 2 hours 
at the bottom of the form (0 days 02:00:00). 
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Select the Resources tab and double-click on OpsTeam from the Defined Resources list 
(OpsTeam should appear in the Resource Constraints formula field).  Click on the         
Create Possibilities button and then click OK. 

Two daily management Report tasks should appear in the Gantt window with timeslots 
corresponding to the periods when the OpsTeam is on duty: 

 

FUSEground Task 

Select Task > New/Insert.  On the General tab of the Task Definition form specify the Task 
Name as FUSEground.  Leave all else on the General tab as default values. 

Select the Scheduling tab and select the Single Instance Task radio-button option. 

Select the Duration tab and select the Fixed duration option.  Specify the duration as 1 minute 
at the bottom of the form (0 days 00:01:00). 

Select the Resources tab and double-click on the FUSE resource from the Defined Resources 
list, then click AND, double-click on the SSR resource, click AND, and finally double-click 
the AmazonTarget resource from the Defined Resources list.  “FUSE” AND “SSR” AND 
“AmazonTarget” should appear in the Resource Constraints formula field.  Click on Create 
Possibilities. 
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Select the Resource Usage tab and then select the SSR resource and Edit.  Specify that the 
FUSEground task Depletes the SSR Capacity by a Fixed amount of 75 Mbytes (see window 
snapshot below), and click OK. 

 

Click OK to apply the task definition.  A single FUSEground task should be added to the 
Gantt window with 5 or 6 scheduling opportunities (timeslots) appearing on each day. 

FUSEscience Task 

Select Task > New/Insert.  On the General tab of the Task Definition window specify the 
Task Name as FUSEscience.  Leave all else on the General tab as default values. 

Select the Scheduling tab and select the Single Instance radio-button option and select the 
checkbox Define More Restrictive Windows in the middle of the form.  Select the Discrete 
Windows tab and click on STK Import, then on Add.  Select the Umbra report type and 
FUSE for STK Object 1.  Leave everything else as the default value and click OK, then OK 
again.  The umbra periods for the duration of the planning period should now be listed in the 
windows area at the bottom of the form: 
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The FUSEscience task will only be scheduled once (single instance task), but it is constrained 
to only be scheduled during the umbra windows determined by STK. 

Select the Duration tab and select the Maximize – Allow Handovers duration option.  Specify 
the Minimum Segment Duration as 5 minutes (0 days 00:05:00), the Minimum Total 
Duration as 40 minutes (0 days 00:40:00),  and the Maximum Duration as 50 minutes (0 
days 00:50:00) at the bottom of the window.  This duration option allows handovers between 
resources as well as non-contiguous task continuation as required to complete the full task 
duration.  None of the FUSE to star access windows are 40 minutes long, but the task can be 
completed in segments, and this task duration option allows that. 

Select the Resources tab and double-click on the FUSE resource from the Defined Resources 
list.  Then click AND.  Finally, double-click the CassiopeiaStar_HR-21 resource from the 
Defined Resources list.  “FUSE” AND “CassiopeiaStar_HR-21” should appear in the 
Resource Constraints formula field.  Click on Create Possibilities, then OK. 

A single FUSEscience task will be added to the Gantt view with repeating windows of 
opportunity on every orbit (constrained to umbra windows and times during which the Earth 
is not occulting the line of sight from the satellite to the star).  Note that none of the windows 
are 40 or 50 minutes long (hover the cursor over a timeslot to get the popup details). 
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FUSEattitude Task 

Select Task > New/Insert.  On the General tab of the Task Definition form specify the Task 
Name as FUSEattitude.  Define the Priority as 10 (making this a low-priority task).  Leave 
all else on the General tab as default values. 

Select the Scheduling tab and select the Recurring task radio-button option and select the 
Time option for the recurring basis.  Select the Discrete Windows tab and click on           
STK Import and Add: 
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Select the Ascending Node report type, FUSE for STK Object 1, and verify that the Window 
Start Time radio button is selected, and enter a Duration of 30 minutes.  Click OK and OK 
again. 30 minute windows beginning at each FUSE ascending node will be listed in the 
windows area of the tab. 

Select the Duration tab and select the Fixed duration option.  Specify the duration as 15 
minutes at the bottom of the window (0 days 00:15:00).  This means that each orbit, 
sometime within 30 minutes of the FUSE ascending node crossing, the software will attempt 
to schedule this 15 minute recurring task. 

Select the Resources tab and double-click on the FUSE resource from the Available 
Resources list.  “FUSE” should appear in the Resource Constraints formula field.  Click on 
Create Possibilities. 

Click OK to apply the task. 

29 FUSEattitude tasks will be created (one for each orbit) and added to the Gantt window 
with a single 30-minute opportunity on every orbit.  Scroll down through the new tasks using 
the scrollbar on the right-hand side of the window: 

 

Select File > Save to save your work before moving on to the next section where you will get 
down to doing some scheduling. 
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Scheduling & Analysis 
Now that you have several tasks defined it is time to solve the schedule! Generate 
deconflicted schedule solutions using one or more of the deconfliction algorithms available in 
STK/Scheduler.  Expect this section to take approximately 15 to 20 minutes to complete. 

Select Schedule > Select Algorithm and choose One-Pass.  Click GO on the main window 
toolbar to initiate the scheduling run using the One-Pass scheduling algorithm.  Click OK 
when the Scheduling Status popup window indicates that the scheduling process is complete.  
A Summary Report form will provide an overview of the scheduling problem and the results 
of the scheduling run: 

 

Click on the Summary Report Close button and review the Gantt form.  Note that scheduled 
tasks are shown as green bars at the time they were assigned by the scheduling algorithm: 
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Tasks are shown in the Gantt view in time order.  Unscheduled tasks are moved to the bottom 
of the form.  This default organization can be adjusted by the user through menu option 
selections under the View menu.   

Select View > Show Timeslots to toggle off the display of timeslots; now only the scheduled 
task bars are shown.  Turn the timeslots back on by selecting View > Show Timeslots again. 

Roll up recurring tasks onto a single line by selecting View > Rollup Tasks > Rollup 
Recurring Tasks.  Remove task labels by de-selecting View > Show Task Labels. 
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Break out each recurring task instance by again selecting View > Rollup Tasks > Do Not 
Rollup Tasks and re-selecting View > Show Task Labels. 

To quickly find a single task in a long task list, click on the binoculars icon on the toolbar.  
Select the desired task and click OK.  The view will shift to place the selected task at the 
center of the Gantt window if the task is not already in the window. 

Tasks may be grouped on the Gantt view based on their assigned STK object type.  Select 
View > Task Groups > by STK Facility: 

 

Note that the tasks with scheduled assignments to STK facility objects have been grouped 
according to their assignment.  Tasks without STK facility assignments are in the Ungrouped 
section at the bottom of the Gantt view (in time order).  Select View > Task Groups > 
Ungrouped to return to the normal time-ordered task view. 

Right-click on a task name or task row for a scheduled task to bring up a menu of task 
options.  Select Edit to bring up the Task Status tab of the Task Definition form.  Note the 
information on start time, stop time, duration, and assigned resource option.  Click Cancel to 
close the window. 
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Scroll down to the bottom of the Gantt view and left click (to clear other task selections) then 
right-click on an unscheduled task.  Select Edit to bring up its Status tab.  Click on Calculate 
Conflicts to display specific conflicts that caused the scheduling problem(s) for the task. 
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Any scheduled task using a resource option for the unscheduled task during any timeslot for 
the unscheduled task will be listed here.  In addition to these direct conflicts, indirect conflicts 
due to resource setup times and consumable resource capacity are also listed.  This provides 
conflict analysis data for unscheduled tasks.  Click Cancel to close the window. 

De-select View > Show Unassigned Tasks to remove unassigned tasks from the Gantt 
window. 

Tasks may be manually dragged to a new time on the Gantt view.  In order to drag a task it 
must be Locked (which indicates a manual override for scheduling purposes).  Right-click on 
one of the scheduled Management Report tasks and select the Lock/Override option.  The 
task bar will turn blue, indicating that it is Locked.  Next, click-and-drag the task bar to a new 
time (perhaps during a different timeslot or maybe during no timeslot at all).  Run a validity 
check by selecting Schedule > Validate and note any violations in the log under Help > Log. 

 
Note 

The user risks over-subscribing a resource by locking and dragging a task 
manually.  Validity checking can confirm that manual changes have not 

violated task or resource attributes. 
 

The Task Lock feature is a manual override so the user can place a task 
anywhere (even outside task timeslots).  Task validity checking is NOT 

performed on locked or deferred tasks, though related resource impacts are 
checked for locked tasks. 

 
Note that locking a task and dragging it to a new timeslot does NOT change 

the resource assignment for the task.  The resource assignment may be 
manually selected on the task’s Task Definition form Status tab. 

 

Select View > Main View > Table or click on the table button on the toolbar to bring up the 
table view of the schedule: 
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Click on column headers to sort by the values of the data in that column.  Click on the 
column header again to reverse the sort.  Sort by the Status column to bring unscheduled 
tasks to the top; this is a quick way to consolidate the unscheduled tasks on the table view.   

Select View > Show Legend to help decipher the symbols used for the different status levels 
and task object type definitions: 

 

Close the Legend form.  On the table view, Click-and-Drag a column header left or right to 
reorder the columns as desired, and resize the columns per your preference. 

Right-click on a scheduled task and select the Lock option from the pop-up menu.  The task 
status bar will turn blue and it will be brought to the top or bottom of the list if the table is 
still sorted by Status.  A locked task (and the resources it uses) will not be changed if the 
schedule is re-solved.  Unlocked tasks and new tasks are scheduled around locked tasks. 

Unlock all tasks and Select Schedule > Select Algorithm > Multi-Pass and then hit GO to 
resolve the schedule.  Perhaps this algorithm did better than the One-Pass algorithm.  The 
Summary Report should tell you how it did, or you can sort by the Status column in the Table 
view. 

Highlight a group of tasks in the table view by selecting them with the mouse and using the 
SHIFT or CTRL keys.  To select all, CTRL-A.  To get a Task-based ASCII report for the 
selected tasks, select Task > Report.   
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All task timeslots as well as the assigned timeslot and resources are listed for each task.  Save 
the task report for later use by clicking Save and selecting a filename and the directory 
location. 

To get a Resource-based report select Resource > Report.  With the mouse select the 
resource or resources you would like a report on and click OK.   

 

Review the Resource report on the screen.  Note that resource duty cycle is calculated and all 
supported tasks are listed under each resource. 

 
V3.0.0 May, 2004 



42 STK/Scheduler Tutorial 

To assess resource capacity usage select Resource > Chart > Capacity.  Zoom in on the main 
Gantt View first to see a closer view of the chart (the main Gantt View zoom setting is used 
to drive the chart zoom level).  The SSR depletion and replenishments are shown. 

 

For operator/planner situational awareness, STK/Scheduler also comes with a schedule 
animation feature.  To help focus in on this schedule’s animation, select FUSE as the focus of 
the VO View.  Look at the Gantt view of STK/Scheduler to find the start time of the 
FUSEcomm task.  Select Schedule > STK > Animate, bring the STK/VO window to the front 
(animation starts automatically), and use the VO window controls to fast-forward the 
animation to just prior to the start of the task, and then slow it down to run at a reasonable 
speed. 

Note the magenta line that appears, connecting FUSE with its assigned target (the facility 
object) during the scheduled task time.  These are not just access lines; they are displayed 
only when a task is scheduled, and only shows accesses assigned by the scheduling algorithm 
to support defined and scheduled tasks.   

The loaded STK scenario is modified to display accesses between STK objects that are being 
used to support scheduled tasks during their tasks’ scheduled times. 
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Tutorial Complete 
This concludes the STK/Scheduler tutorial.  To save this schedule file select File > Save.  
The saved schedule file includes all of the information about all of the tasks and resources, 
scheduling options, timeslots, and other data necessary to bring the planning session back so 
you can start where you left off.  Note that resources and tasks are unique to and not shared 
between schedule files, even though they might be associated with the same object in the 
same STK scenario.   

Please feel free to experiment by adding to the schedule file you built here or by creating a 
new file from scratch.  Remember that form-specific HTML Help is just a mouse click away 
to provide more information about any field or parameter. 

If you have any questions regarding STK/Scheduler, other STK modules, or this tutorial, 
please email STK technical support at support@stk.com or contact technical support by 
phone at 888-785-9973 (weekdays between 8am and 8pm, Eastern Time). 
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